Avid Media ComposerAvid Media Composer v3.0.1 is an updated version of v3.0 that runs on OS X 10.4.11 (Tiger) for Media Composer Adrenaline™ and Media Composer with Avid Mojo® (classic) orAvid Mojo SDI customers. Avid Media Composer Adrenaline, Avid Mojo and Avid Mojo SDI are not qualified with Mac OS X 10.5 (Leopard) due to an issue between the Apple firewire driver in Apple OS X 10.5 and the Avid Adrenaline and Avid Mojo drivers. This issue is not present with Apple OS X 10.4 Tiger and therefore Avid has released v3.0.1 for OS X 10.4 so that Avid Adrenaline and Avid Mojo customers can upgrade to v3.

This release is ONLY for Media Composer Adrenaline/Avid Mojo/Avid Mojo SDI customers on the Mac. All other customers and customers using the new systems should continue to use v3.0. The following table summarizes compatibility and will assist you in understanding if this release applies to you.
Supported v3 releases by platform and operating system

Editor
Mac OS X 10.4.11
Mac OS X 10.5.3
Windows XP
Windows Vista
Media Composer Software
V3.0.1
V3.0
V3.0
Media Composer Software with Mojo or Mojo SDI
V3.0.1
Not supported
V3.0
Media Composer Adrenaline
V3.0.1
Not supported
V3.0
Media Composer Mojo DX
Not supported
V3.0
V3.0
Media Composer Nitris® DX
Not supported
V3.0
V3.0
Symphony™ Nitris DX
Not supported
V3.0
V3.0

How to obtain your software
v3.0 or v3.0.1 can be obtained in one of the following ways:

  1. You have a valid Avid Assurance Support contract. The v3.0 or v3.0.1 software is available to Avid Assurance customers at no additional charge. Software upgrades are a feature of Avid Assurance contracts. The software can be obtained by logging into the Avid Electronic Download Center.
  2. You purchased a new copy, or purchased an upgrade to Avid Media Composer v2.8 after March 17th 2008. The v3.0 or v3.0.1 software is free of charge and can be obtained by going to http://www.avid.com/protect. You will be asked to enter the location and the date of purchase, as well as the System ID as proof of purchase. Offer ends July 15th 2008.
  3. You purchased v3.0 after June 6th 2008 and you want v3.0.1: you can obtain v3.0.1 from the v3.0.1 update page.
  4. You do not fall into one of the above categories. You can either purchase an Avid Assurance contract or you can purchase the v3.0/v3.0.1 upgrade from Videoguys.com.
Avid

Leave a comment

All comments are moderated before being published